Hello 929 from Perth, Australia

User avatar
ny4n
Registered users
Registered users
Posts: 30
Joined: Thu Feb 04, 2010 3:10 pm
Make: Mazda
Model: 929
Year: 1995
Body Code: HD
Location: Perth, Western Australia

Hello 929 from Perth, Australia

Postby ny4n » Tue Mar 02, 2010 2:46 pm

Hey all. I've been looking around this site for a while. Just haven't joined.. until now. I have a 1995 HD 929. Have had it for over 2 years now. I think it a terrific car. I love it. Very underrated car though.. wish more people would appreciate it. I'll add some pictures when I figure out how to.

User avatar
jitb
Site Admin
Site Admin
Posts: 167
Joined: Wed Jun 17, 2009 9:01 pm
Location: Atlanta, GA USA
Contact:

Re: Hello 929 from Perth, Australia

Postby jitb » Wed Mar 03, 2010 5:39 am

welcome! cant wait to see pics!
Image

User avatar
Matsuda9
Site Admin
Site Admin
Posts: 610
Joined: Thu Jun 18, 2009 11:09 am
Make: Mazda
Model: Luce
Year: 1988
Body Code: HCFS
Location: Melbourne, AU
Contact:

Re: Hello 929 from Perth, Australia

Postby Matsuda9 » Wed Mar 03, 2010 6:31 am

welcome.... getting more and more HDers :)
Image

User avatar
ny4n
Registered users
Registered users
Posts: 30
Joined: Thu Feb 04, 2010 3:10 pm
Make: Mazda
Model: 929
Year: 1995
Body Code: HD
Location: Perth, Western Australia

Re: Hello 929 from Perth, Australia

Postby ny4n » Fri Mar 05, 2010 2:22 am

thanks guys. jitb... you would've seen my car on ozmazdaclub.com a long time ago. Two tone.. white on top brown-ish at the bottom.

User avatar
JAY-929
Global Moderator
Global Moderator
Posts: 264
Joined: Tue Nov 03, 2009 10:22 pm
Make: Mazda
Model: 929
Year: 1988
Body Code: HC01
Location: Melbourne, Victoria, AU

Re: Hello 929 from Perth, Australia

Postby JAY-929 » Fri Mar 05, 2010 4:08 am

Welcome aboard :)
1988 MAZDA 929 HC SERIES 1 HARDTOP
CURRENTLY UNDER CONSTRUCTION

User avatar
ny4n
Registered users
Registered users
Posts: 30
Joined: Thu Feb 04, 2010 3:10 pm
Make: Mazda
Model: 929
Year: 1995
Body Code: HD
Location: Perth, Western Australia

Hello 929 from Perth, Australia

Postby ny4n » Fri Mar 19, 2010 3:06 pm

Image

Image

Image

Image
this was when I fixed up all the major stuff like timing belt, all the seals, water pump, hydraulic tensioner .. and the list goes on. For some reason there is still quite a bit of oil leak. I'm pretty sure its not the Rocker covers cause i changed all the seals one year ago. Anyone got any idea?

User avatar
jitb
Site Admin
Site Admin
Posts: 167
Joined: Wed Jun 17, 2009 9:01 pm
Location: Atlanta, GA USA
Contact:

Re: Hello 929 from Perth, Australia

Postby jitb » Thu Mar 25, 2010 3:27 pm

how was that job? seems to be easy to fix on the 9 due to room... any problems with the timing etc?
Image

User avatar
ny4n
Registered users
Registered users
Posts: 30
Joined: Thu Feb 04, 2010 3:10 pm
Make: Mazda
Model: 929
Year: 1995
Body Code: HD
Location: Perth, Western Australia

Re: Hello 929 from Perth, Australia

Postby ny4n » Tue Mar 30, 2010 1:08 pm

the job was pretty hard. had to get a mechanic friend to help me out. not enough space either . had to remove the radiator, fan, battery, etc. but after removing all that it was fine. the timing is fine. drives fine. but the damn oil leak is bugging me.

User avatar
Matsuda9
Site Admin
Site Admin
Posts: 610
Joined: Thu Jun 18, 2009 11:09 am
Make: Mazda
Model: Luce
Year: 1988
Body Code: HCFS
Location: Melbourne, AU
Contact:

Re: Hello 929 from Perth, Australia

Postby Matsuda9 » Tue Mar 30, 2010 9:12 pm

many aftermarket seals only leave 6-18 months so it is possible that it is leaking from cams/crank.... especially if the spring has popped
Image

User avatar
ny4n
Registered users
Registered users
Posts: 30
Joined: Thu Feb 04, 2010 3:10 pm
Make: Mazda
Model: 929
Year: 1995
Body Code: HD
Location: Perth, Western Australia

Re: Hello 929 from Perth, Australia

Postby ny4n » Wed Apr 14, 2010 6:29 am

Matsuda9 wrote:many aftermarket seals only leave 6-18 months so it is possible that it is leaking from cams/crank.... especially if the spring has popped


i see ... i changed it less than 6 months ago though. so it must be leaking from somewhere else. i'm gonna take it to a mechanic soon to sort everything out.


Return to “Introductions”

Who is online

Users browsing this forum: No registered users and 1 guest