No spark no injector pulse

User avatar
Rj7926
Registered users
Registered users
Posts: 5
Joined: Thu Sep 06, 2012 12:03 am
Make: Mazda
Model: 929
Year: 1989
Body Code: HC

No spark no injector pulse

Postby Rj7926 » Thu Sep 06, 2012 12:14 am

Good morning ladies and gentleman I just bought my Hc from my naibour, it's been of the road for 4 years he was going to put in a 1j and all that and since has gone back to his 4x4. The car was pulled of the road because one of the cam gears had come loose I've since replaced the gear put on a new timing belt and timed it by the book. The car cranks over fine no binding or any of that but I have no spark and no injector pulse I've checked all the fuses and I'm under the belief the relays are ok. I'm really at a loss from this point if anyone can help I'd be very very very great full.
Tempt not the devil :P

User avatar
Rj7926
Registered users
Registered users
Posts: 5
Joined: Thu Sep 06, 2012 12:03 am
Make: Mazda
Model: 929
Year: 1989
Body Code: HC

Re: No spark no injector pulse

Postby Rj7926 » Sat Sep 08, 2012 3:33 am

Ok so it was a small error on my end the engine sensor fuse was blown replaced it its in the fuse panel in the car btw its 15amp just incase it helps anyone.Now I have injectors back but still no spark but I have 12 volts to the coil I tried a different coil and still nothing so my next step is the ignighter any ideas how to test it because the Chiltons manual doesn't mention it any ideas?
Tempt not the devil :P

User avatar
Matsuda9
Site Admin
Site Admin
Posts: 610
Joined: Thu Jun 18, 2009 11:09 am
Make: Mazda
Model: Luce
Year: 1988
Body Code: HCFS
Location: Melbourne, AU
Contact:

Re: No spark no injector pulse

Postby Matsuda9 » Sat Sep 08, 2012 12:26 pm

First off, Welcome :)

Glad you figured your problem 1/2 way :)

There is no testing for the igniter, replace and test only :( I guess this is the reason i keep 3 or so working units nearby.

here is troubleshoot procedure for hard start...
Image
Image

User avatar
Rj7926
Registered users
Registered users
Posts: 5
Joined: Thu Sep 06, 2012 12:03 am
Make: Mazda
Model: 929
Year: 1989
Body Code: HC

Re: No spark no injector pulse

Postby Rj7926 » Fri Sep 14, 2012 8:46 am

Thanks heaps for the worm welcome and the info matsuda. I've since replaced the ignighter but still no spark the computer is still giving me code 1 ( btw the code is able to be cleared and it shows when I unplug other things so the ecu should be ok). Would anyone know what wire of the ecu controls spark I thought it would be the same as the iGt wire from the ignighter but it's not again all help is much lay appreciated.
Tempt not the devil :P

User avatar
Rj7926
Registered users
Registered users
Posts: 5
Joined: Thu Sep 06, 2012 12:03 am
Make: Mazda
Model: 929
Year: 1989
Body Code: HC

Re: No spark no injector pulse

Postby Rj7926 » Thu Sep 20, 2012 8:37 am

Ok so we have spark fuel and compression the timeing is spot on still not kickin plugs are wet btw so injectors are goin.... But the car is not any thoughts?
Tempt not the devil :P


Return to “Maintenance Works”

Who is online

Users browsing this forum: No registered users and 1 guest